【安全提醒】PHP-FPM远程代码执行漏洞,PHP请及时更新

虚竹 21天前 108

PHP请更新到以下版本以上:
5.5.38-12
5.6.40-14
7.0.33-14
7.1.28
7.2.17
7.3.4

漏洞编号:

CVE-2019-11043

漏洞描述:

2019年9月26日,PHP官方发布了PHP-FPM存在远程代码执行漏洞的补丁公告。在Nginx搭载PHP-FPM的组合下,当FastCGI配置不当时,存在本漏洞。

漏洞详情:

当Nginx使用了早期示例FastCGI配置时,PHP-FPM会触发本漏洞。
Nginx具体配置为fastcgi_split_path_info ^(.+?.php)(/.*)$;,在这种情况下,攻击者可以通过精心构造payload,触发远程代码执行漏洞,目前在GitHub公开的POC是写入一个WebShell到网站目录下,从而开启后门创建。
但在PHP >= 5.3.3后,PHP-FPM并入PHP核心。

危害程度:

高危

涉及版本:

官方可确认在PHP 7系列版本中包含本漏洞,此前版本官方未明确确认。

其他信息:

目前漏洞细节和POC已经公开,建议及时升级安全更新补丁或使用官方推荐的配置示例。

最新回复 (0)
返回
发新帖