安装appnode 失败 提示

fwy12345 4月前 114

提示如下

Transaction check error:

file /etc/my.cnf from install of appnode-mysql56-libs-5.6.41-1.el7.x86_64 conflicts with file from package appnode-mariadb102-config-3:10.2.12-3.el7.x86_64
file /usr/bin/mysql_config from install of appnode-mysql56-5.6.41-1.el7.x86_64 conflicts with file from package mariadb-connector-c-devel-3.0.3-1.el7.x86_64

Error Summary


ERROR: install environment softwares failed: exit status 1

应该如何解决?

最新回复 (5)
  • 虚竹 4月前
    引用 2

    如果是在软件管家中安装的,如果检测到冲突,有解决方案的情况下,按解决方案提醒的操作。

    没有的话,需要使用命令强制卸载系统中冲突的安装包,如:rpm -e --nodeps appnode-mariadb102-config

    具体要卸载哪个安装包,要看你当前安装的版本是什么,系统中原有的版本是什么,一般是卸载系统中原有的版本。

  • fwy12345 4月前
    引用 3
    不是 我是之前安装过这个集成环境。然后被别人失误卸载了数据库,然后我重装面板就这样了
  • 虚竹 4月前
    引用 4
    重装时,需要安装原来同版本的数据库,不然就会出来上面的版本冲突错误。
  • fwy12345 4月前
    引用 5
    我是安装的相同版本的
  • fwy12345 4月前
    引用 6
    虚竹 重装时,需要安装原来同版本的数据库,不然就会出来上面的版本冲突错误。
    还是不行额
返回
发新帖