通过appnode安装php报错

oneing 23天前 47

Repository epel is listed more than once in the configuration
appnode | 3.0 kB 00:00:00
appnode-agent | 2.9 kB 00:00:00
appnode-agent-development | 2.9 kB 00:00:00
appnode-ccenter | 2.9 kB 00:00:00
appnode-ccenter-development | 2.9 kB 00:00:00
appnode-development | 3.0 kB 00:00:00
appnode-extras | 2.9 kB 00:00:00
appnode-extras-development | 2.9 kB 00:00:00
code | 2.9 kB 00:00:00
epel | 4.7 kB 00:00:00
extras | 3.4 kB 00:00:00
os | 3.6 kB 00:00:00
pkerling-seafile | 3.0 kB 00:00:00
updates | 3.4 kB 00:00:00
(1/2): epel/7/x86_64/updateinfo | 957 kB 00:00:00
(2/2): epel/7/x86_64/primary_db | 6.6 MB 00:00:01
Resolving Dependencies
--> Running transaction check
---> Package appnode-php73-php.x86_64 0:7.3.1-1.el7 will be installed
--> Processing Dependency: httpd-mmn = 20120211x8664 for package: appnode-php73-php-7.3.1-1.el7.x86_64
--> Processing Dependency: httpd for package: appnode-php73-php-7.3.1-1.el7.x86_64
--> Processing Dependency: libargon2.so.0()(64bit) for package: appnode-php73-php-7.3.1-1.el7.x86_64
---> Package appnode-php73-php-cli.x86_64 0:7.3.1-1.el7 will be installed
---> Package appnode-php73-php-common.x86_64 0:7.3.1-1.el7 will be installed
--> Processing Dependency: appnode-php73-php-json(x86-64) = 7.3.1-1.el7 for package: appnode-php73-php-common-7.3.1-1.el7.x86_64
---> Package appnode-php73-php-fpm.x86_64 0:7.3.1-1.el7 will be installed
---> Package appnode-php73-php-pear.noarch 1:1.10.7-3.el7 will be installed
--> Processing Dependency: appnode-php73-php-posix for package: 1:appnode-php73-php-pear-1.10.7-3.el7.noarch
--> Processing Dependency: appnode-php73-php-xml for package: 1:appnode-php73-php-pear-1.10.7-3.el7.noarch
---> Package appnode-php73-runtime.x86_64 0:1.0-1.el7 will be installed
--> Processing Dependency: environment-modules for package: appnode-php73-runtime-1.0-1.el7.x86_64
--> Running transaction check
---> Package appnode-php73-php.x86_64 0:7.3.1-1.el7 will be installed
--> Processing Dependency: httpd-mmn = 20120211x8664 for package: appnode-php73-php-7.3.1-1.el7.x86_64
--> Processing Dependency: httpd for package: appnode-php73-php-7.3.1-1.el7.x86_64
---> Package appnode-php73-php-json.x86_64 0:7.3.1-1.el7 will be installed
---> Package appnode-php73-php-process.x86_64 0:7.3.1-1.el7 will be installed
---> Package appnode-php73-php-xml.x86_64 0:7.3.1-1.el7 will be installed
---> Package environment-modules.x86_64 0:3.2.10-10.el7 will be installed
--> Processing Dependency: libtcl8.5.so()(64bit) for package: environment-modules-3.2.10-10.el7.x86_64
---> Package libargon2.x86_64 0:20161029-2.el7 will be installed
--> Running transaction check
---> Package appnode-php73-php.x86_64 0:7.3.1-1.el7 will be installed
--> Processing Dependency: httpd-mmn = 20120211x8664 for package: appnode-php73-php-7.3.1-1.el7.x86_64
--> Processing Dependency: httpd for package: appnode-php73-php-7.3.1-1.el7.x86_64
---> Package tcl.x86_64 1:8.5.13-8.el7 will be installed
--> Finished Dependency Resolution
Error: Package: appnode-php73-php-7.3.1-1.el7.x86_64 (appnode)
Requires: httpd-mmn = 20120211x8664
Error: Package: appnode-php73-php-7.3.1-1.el7.x86_64 (appnode)
Requires: httpd
You could try using --skip-broken to work around the problem
** Found 2 pre-existing rpmdb problem(s), 'yum check' output follows:
2:postfix-2.10.1-7.el7.x86_64 has missing requires of libmysqlclient.so.18()(64bit)
2:postfix-2.10.1-7.el7.x86_64 has missing requires of libmysqlclient.so.18(libmysqlclient_18)(64bit)



求解,谢谢

最新回复 (1)
  • oneing 23天前
    引用 2
    appnode中提示:
    安装PHP环境失败:未知错误
    软件冲突: 暂无解决方案
返回
发新帖