请选择 进入手机版 | 继续访问电脑版
用户
请注意:社区账号与官网账号不互通,如需登录社区,请在此注册社区账号!
 找回密码
 注册社区账号

QQ登录

只需一步,快速开始

搜索

APPNODE 最好还能提供第三方软件源的使用

使用交流 2018-01-06 12:42 [复制链接] 查看: 101|回复: 6
APPNODE 官方提供的 PHP、MariaDB 版本号跟进太慢了,现在都 PHP 7.2.1 了还停留在 7.2.0,MariaDB 也没有 10.2 提供。

目前自己设计的 REMI 的PHP和MariaDB官方的二进制版,但是网站管理无法识别自己安装的环境。

希望能整合第三方软件源的使用,给用户多一种选择
回复

使用道具 举报

虚竹 发表于 2018-1-6 14:12:30 | 显示全部楼层
PHP 7.2.1 才出来2天呢

MariaDB如果IUS源更新了,我们也会同步更新。

会考虑增加对REMI源软件的兼容。
回复 支持 反对

使用道具 举报

ivmm  楼主| 发表于 2018-1-6 17:05:19 | 显示全部楼层
虚竹 发表于 2018-1-6 14:12
PHP 7.2.1 才出来2天呢

MariaDB如果IUS源更新了,我们也会同步更新。

我觉得 MariaDB 还是考虑兼容 MariadDB 官方的就行,没人比官方更懂 MariadDB 了。

我对软件的安全更新还是很重视的,最好就是当天更新
回复 支持 反对

使用道具 举报

虚竹 发表于 2018-1-6 18:35:36 | 显示全部楼层
ivmm 发表于 2018-1-6 17:05
我觉得 MariaDB 还是考虑兼容 MariadDB 官方的就行,没人比官方更懂 MariadDB 了。

我对软件的安全更新 ...

本来是想要参考官方的,但是官方的 MariaDB RPM 包没有提供 src 包(他们使用了独特的打包方式),自己写维护量太大,不太实际。

Why MariaDB RPMs Don't Include the Source RPM (SRPMS):
https://mariadb.com/kb/en/librar ... e-source-rpm-srpms/
回复 支持 反对

使用道具 举报

ivmm  楼主| 发表于 2018-1-6 21:43:53 | 显示全部楼层
虚竹 发表于 2018-1-6 18:35
本来是想要参考官方的,但是官方的 MariaDB RPM 包没有提供 src 包(他们使用了独特的打包方式),自己写 ...

一般用户不会考虑要使用到 src 包吧
回复 支持 反对

使用道具 举报

虚竹 发表于 2018-1-7 17:16:33 | 显示全部楼层
ivmm 发表于 2018-1-6 21:43
一般用户不会考虑要使用到 src 包吧

是我们需要用到,自己写打包配置文件的话,更新和软件漏洞修复方面肯定不如remi和ius,因此我们的打包配置文件基本上是来自于remi和ius。

可以参考这里:
https://bbs.appnode.com/thread-533-1-1.html
回复 支持 反对

使用道具 举报

ivmm  楼主| 发表于 2018-1-7 18:06:38 | 显示全部楼层
虚竹 发表于 2018-1-7 17:16
是我们需要用到,自己写打包配置文件的话,更新和软件漏洞修复方面肯定不如remi和ius,因此我们的打包配 ...

还是希望能兼容用户自行安全的解决方案,我目前把自己的环境都设置好了以后,网站管理哪里无法使用自行安装的二进制版本管理。

多一次封装就多了一次延时,还是包容一点得好

数据库可以考虑添加 Percona,提供 src https://repo.percona.com/release/7/SRPMS/
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册社区账号

本版积分规则

温馨提示
为了能您的问题能够尽快得到解决,复杂问题建议您直接提交工单处理。
QQ群:744188

Archiver|手机版|AppNode 用户社区

GMT+8, 2018-1-22 10:12

Powered by Discuz! X3.2

© 2001-2013 Comsenz Inc.

快速回复 返回列表