allow_url_fopen开启了。phpinfo 也看到了,但用脚本检测提示没开启allow_url_fopen

Jeo 2018-8-23 495

今天用appnode,搭建了xiuno论坛,发现插件中心打开空白,按教程https://bbs.xiuno.com/thread-20496.htm开启debug,发现是allow_url_fopen没开启,1我在appnode的PHP全局那操作了开启allow_url_fopen,phpinfo 也看到了,
但还是错误,网上搜索了下,用这个PHP代码检测allow_url_fopen是否开启,发现是没开启的,
<?php
if( ini_get('allow_url_fopen') ) {
die('allow_url_fopen is enabled. file_get_contents should work well');
} else {
die('allow_url_fopen is disabled. file_get_contents would not work');
}

?>




然后我查看PHP.ini
allow_url_fopen是关闭的,没更改

最新回复 (4)
  • 虚竹 2018-8-23
    引用 2
    php.ini里是全局的配置,网站设置中设置的是针对网站的设置,网站设置会覆盖全局设置。
    你可以看下网站目录下的 conf/php-*.conf,这个才是针对各个网站的php设置。

    设置修改后,需要重启PHP服务,在网站中才会生效(在面板中查看phpinfo不需要重启即可生效)。
  • Jeo 2018-8-23
    引用 3
    虚竹 php.ini里是全局的配置,网站设置中设置的是针对网站的设置,网站设置会覆盖全局设置。 你可以看下网站目录下的 conf/php-*.conf,这个才是针对各个网站的php设置。 设置修改后 ...
    好的,默认是关闭的,按你的说明我开启了。
  • xiaohi 18天前
    引用 4
    遇到同样的问题  fopen打不开
  • 虚竹 17天前
    引用 5
    网站管理中:网站设置-PHP-安全设置,勾选允许打开远程资源,并在禁用函数列表中去除fopen(如果有被禁用)。
返回
发新帖